Это моя сеть:
Я сделал все возможное, чтобы попытаться решить проблему, но безуспешно. Всякий раз, когда пакеты приходят из LAN 1 или LAN 3, локальные IP-адреса преобразуются в один из 3 общедоступных адресов, доступных каждому маршрутизатору, но пакеты из LAN 2 или 4 немедленно отбрасываются маршрутизатором, который говорит: «Устройство не может выделить доступное IP-адрес для перевода. Это отбрасывает пакет ".
Таким образом, хотя пакеты маршрутизируются из LAN 1 и 3, они никогда не возвращаются. Маршрутизатор не может преобразовать общедоступный IP-адрес, указанный в качестве пункта назначения в пакете, в правильный частный IP-адрес компьютера, который отправил пакет. Например, пинг из LAN 1 в LAN 3 (LAN 2 и 4, как я уже упоминал ранее, немедленно отбрасывает пакеты) корректно перемещается туда и обратно от Router0, но затем к тому же Router0, видя, что адресат ответа является одним из его адреса интерфейсов сбрасывают пакет, говоря, что он никогда не отправлял эхо-запрос, и поэтому не ожидал никакого эхо-ответа. Возможно, я что-то упускаю, и я признаю, что все еще не могу полностью понять, как на самом деле работают NAT и PAT (и мой учитель вообще не помогает), но я не знаю, с чего начать, чтобы все работало.
Сейчас я выложу 4 конфигурации запуска маршрутизатора.
Router0
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial2/0
ip address 200.200.0.1 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial3/0
ip address 200.200.3.2 255.255.255.252
ip nat outside
!
interface FastEthernet4/0
ip address 200.200.4.1 255.255.255.252
ip nat outside
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 200.200.0.0 0.0.0.3 area 0
network 200.200.4.0 0.0.0.3 area 0
network 200.200.3.0 0.0.0.3 area 0
!
ip nat inside source list 101 interface FastEthernet4/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 101 permit ip any any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Router1
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial2/0
ip address 200.200.3.1 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial3/0
ip address 200.200.2.2 255.255.255.252
ip nat outside
!
interface FastEthernet4/0
ip address 200.200.5.2 255.255.255.252
ip nat outside
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 200.200.3.0 0.0.0.3 area 0
network 200.200.5.0 0.0.0.3 area 0
network 200.200.2.0 0.0.0.3 area 0
!
ip nat inside source list 101 interface FastEthernet4/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 101 permit ip any any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Роутер2
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial2/0
ip address 200.200.1.1 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial3/0
ip address 200.200.0.2 255.255.255.252
ip nat outside
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
ip address 200.200.5.1 255.255.255.252
ip nat outside
!
router ospf 1
log-adjacency-changes
network 200.200.1.0 0.0.0.3 area 0
network 200.200.5.0 0.0.0.3 area 0
network 200.200.0.0 0.0.0.3 area 0
!
ip nat inside source list 101 interface FastEthernet4/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 101 permit ip any any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Router3
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial2/0
ip address 200.200.2.1 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial3/0
ip address 200.200.1.2 255.255.255.252
ip nat outside
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
ip address 200.200.4.2 255.255.255.252
ip nat outside
!
router ospf 1
log-adjacency-changes
network 200.200.2.0 0.0.0.3 area 0
network 200.200.4.0 0.0.0.3 area 0
network 200.200.1.0 0.0.0.3 area 0
!
ip nat inside source list 101 interface FastEthernet4/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 101 permit ip any any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Заранее спасибо.